funções de data e hora

Como calcular a idade de uma pessoa?

Para calcular a idade atualizada de uma pessoa a partir de sua data de nascimento, utilizaremos as funções HOJE(), DIA(núm_série), MÊS(núm_série), ANO(núm_série) e DATA(ano; mês; dia):

Se a data de nascimento estiver na célula A1, você pode utilizar a fórmula a seguir para chegar à idade correspondente:

=SE(DATA(ANO(HOJE());MÊS(HOJE());DIA(HOJE()))>=DATA(ANO(HOJE());MÊS(A1);DIA(A1));ANO(HOJE())-ANO(A1);ANO(HOJE())-1-ANO(A1))

Interpretação da fórmula acima: se a data de hoje é mais recente ou coincide com a data de aniversário do nascimento, subtrair ano de nascimento do ano atual. Senão, subtrair ano de nascimento do ano anterior.

Como calcular a quantidade máxima de dias em um mês qualquer?

Os meses do ano no calendário ocidental podem variar de 28 a 31 dias. E existem situações em que precisamos dividir um determinado valor pela quantidade de dias de um certo mês: salário/dia, ligações/dia, exercícios/dia etc.

Você pode resolver isso com fórmulas complicadas para testar se o mês é de 30 ou 31 dias ou, em sendo mês de fevereiro, se o ano desejado é bissexto ou não. Mas seria muito mais simples utilizar a seguinte fórmula para descobrir, a qualquer momento, a quantidade de dias de qualquer mês desejado.

Para isso, utilizaremos as funções DIA(núm_série) e DATA(ano; mês; dia), como nos exemplos:

=DIA(DATA(2010;2;0))
=DIA(DATA(2010;3;0))
=DIA(DATA(2010;4;0))
=DIA(DATA(2010;5;0))

Interpretação da fórmula acima: retorne o dia anterior ao primeiro dia do mês seguinte.

Para entender melhor o que fizemos, lembre que DATA(2010;3;1) retornaria
a data 01/03/2010, o primeiro dia do mês desejado (março/2010). Então, DATA(2010;4;0) retornará exatamente o dia imediatamente anterior (1-1=0) ao primeiro dia do mês seguinte (3+1=4) ao desejado (3), ou seja: 31/03/2010.

Como DIA() retorna apenas o dia de uma data, o resultado será sempre a quantidade máxima de dias do mês.

Trabalhando com datas na planilha

Outra dúvida freqüente é sobre como utilizar valores de datas nas mais diversas situações. Reunimos algumas das principais questões aqui nesta página.

Antes disso, faremos uma breve revisão das funções para você:

  • AGORA() – essa função retorna o a data e hora atuais no formato de número de série. O resultado dessa função pode ser utilizado como se você tivesse digitado uma data no formato mm/dd/aaaa hh:mm;
  • DIA(núm_série), MÊS(núm_série), ANO(núm_série) – essas funções retornam apenas o dia, o mês ou o ano de uma determinada data no formato numérico;
  • DATA(ano; mês; dia) – essa função recebe valores numéricos e retorna uma data no formato de número de série.

A função de exemplo abaixo retorna a data de hoje, excluindo a parte das horas:

=DATA(ANO(AGORA());MÊS(AGORA());DIA(AGORA()))

Principais dúvidas

Como calcular a diferença de dias entre datas?

Para encontrar a quantidade de dias entre datas das células A4 e B4, você pode simplesmente aplicar a fórmula abaixo:

=B4-A4+1

Ou, para encontrar a diferença de dias da célula A4 até hoje:

=DATA(ANO(AGORA());MÊS(AGORA());DIA(AGORA())) – DATA(ANO(A4);MÊS(A4);DIA(A4))+1