Como calcular o semestre a partir de uma data qualquer?

por Equipe do blog

Aprenda aplicar a função MÊS() combinada com a função INT(), ou simplesmente a função SE(), para obter o semestre correspondente a partir de qualquer data em sua planilha.

Copie também fórmulas prontas para bimestres, trimestres e quadrimestres.

Utilizando a função MÊS(data) e a função INT(valor numérico)

Faculdades e demais instituições de ensino superior frequentemente utilizam o semestre como unidade de agrupamento dos períodos letivos. É possível utilizar a mesma fórmula matemática explicada no início do artigo para agrupar os meses em dois grupos de 6, a partir de janeiro e de julho.

Para associar automaticamente qualquer data do ano na célula B2 ao semestre correspondente, utilizaremos uma fórmula matemática que calcula quantos semestres completos ocorreram até o mês anterior e depois soma 1 para retornar o semestre da data atual:

=INT((MÊS(B2)-1)/6)+1

Para associar automaticamente os meses do ano ao semestre correspondente, utilize 6 no denominador da fórmula.

Copie daqui e substitua a célula B30 pela célula desejada:

=INT((MÊS(B30)-1)/6)+1

Utilizando a função SE()

Outra possibilidade para calcular o semestre, considerando que há apenas dois resultados possíveis por ano, é testar apenas o mês da data especificada na célula, retornando 2 a partir do 7º mês e retornando 1 nos demais casos:

Copie daqui e substitua a célula B39 pela célula desejada:

=SE(MÊS(B39)>=7;2;1)

Disponibilidade nos editores de planilha

As funções SE(), INT() e MÊS() estão implementadas no Microsoft Excel e no Planilhas Google.

RETRIBUA COMO PUDER

Você tem Instagram?

Clique aqui para me seguir no @reidasplanilhas! 😀

Compartilhe com seus contatos

Clique em uma das redes sociais abaixo para divulgar esta planilha com amigos e familiares:

Muito obrigado! 😀

Lista de marcadores

Encontre conteúdos semelhantes clicando em um dos marcadores abaixo.

Quem gostou, também leu...

Nosso blog necessita utilizar cookies para aprimorar a sua experiência e monetizar nosso conteúdo. Acreditamos que você não veja problemas nisso, mas você pode optar por sair se desejar. Aceitar Saiba mais