Como alternar o valor de uma célula de acordo com um determinado critério?

por Equipe do blog

=SE(teste_lógico; valor_se_verdadeiro; valor_se_falso)

A função SE() avalia um determinado critério (teste_lógico) e retorna um valor de acordo com o resultado do teste:

  • Se o teste lógico retornar VERDADEIRO, a função assumirá o valor que você inserir após o critério, no argumento valor_se_verdadeiro;
  • Se o teste retornar FALSO, a função receberá o valor_se_falso que você determinar.

A função SE() está implementada no Microsoft Excel e no Planilhas Google.

Exemplos de aplicação

Seguem abaixo alguns exemplos de usos da função SE() com testes lógicos que você pode adaptar.

No exemplo abaixo, há um cadastro de alunos candidatos a uma escola de música contendo a pontuação e o turno de estudo de preferência. O primeiro teste limita a pontuação do aluno no teste a 10 pontos se tiver obtido pontuação acima de 10.

Copie a fórmula daqui e altere o endereço C3 para a célula que desejar em sua planilha:

=SE(C3>10;10;C3)

Nesse outro exemplo, utilizamos a coluna Mínimo para aplicar uma nota de corte aos candidatos selecionados. Se a pontuação tiver sido maior que 9, um X é marcado na célula do teste.

Copie a fórmula daqui e altere os endereços C13 e D13 para as células que desejar em sua planilha:

=SE(C13>=D13;"X";"")

Agora, cada candidato escolheu um turno de preferência para ser matriculado. No entanto, a escola precisará enturmar os alunos que não escolheram o turno da MANHÃ no turno da TARDE.

Copie a fórmula daqui e altere o endereço E23 para a célula que desejar em sua planilha:

=SE(E23="MANHÃ";E23;"TARDE")

Agora, considere um cadastro de inscritos em um evento para o qual será necessário atribuir automaticamente as situações EM ESPERA ou CONFIRMADO, pelo seguinte critério: se o número da inscrição for menor ou igual a 100, os candidatos ficarão na lista dos participantes confirmados. Os demais ficarão na lista de espera.

Veja como seria a solução para a lista de inscrição:

Copie a fórmula daqui e altere o endereço B3 para a célula que desejar em sua planilha:

=SE(B3<=100;"CONFIRMADO";"EM ESPERA")
RETRIBUA COMO PUDER

Você tem Instagram?

Clique aqui para me seguir no @reidasplanilhas! 😀

Faça uma doação em ambiente seguro

Valorizamos muito pequenas contribuições de até R$ 10,00. Elas são uma ótima maneira de registrar o seu apoio e não comprometem o seu orçamento. Pague-me um cafezinho! 😉

Clique no botão azul, para fazer uma doação:

Compartilhe com seus contatos

Clique em uma das redes sociais abaixo para divulgar esta planilha com amigos e familiares:

Muito obrigado! 😀

Lista de marcadores

Encontre conteúdos semelhantes clicando em um dos marcadores abaixo.

Quem gostou, também leu...

Nosso blog necessita utilizar cookies para aprimorar a sua experiência e monetizar nosso conteúdo. Acreditamos que você não veja problemas nisso, mas você pode optar por sair se desejar. Aceitar Saiba mais