Como alternar o valor de uma célula de acordo com um determinado critério?

por Equipe do blog

=SE(teste_lógico; valor_se_verdadeiro; valor_se_falso)

A função SE() avalia um determinado critério (teste_lógico) e retorna um valor de acordo com o resultado do teste:

  • Se o teste lógico retornar VERDADEIRO, a função assumirá o valor que você inserir após o critério, no argumento valor_se_verdadeiro;
  • Se o teste retornar FALSO, a função receberá o valor_se_falso que você determinar.

Seguem abaixo alguns exemplos de usos da função SE() com testes lógicos que você pode adaptar:

Fórmula Descrição do teste lógico
=SE(B2>10;5;10) Se o valor da célula B2 é maior que 10, retorne 5 (VERDADEIRO), senão, retorne 10 (FALSO)
=SE(B2>C2;”X”;””) Se o valor da célula B2 é maior que o valor da célula C2, marque com “X”, senão, retorne vazio
=SE(D2=”MANHÔ;”TURMA A”;”TURMA B”) Se o valor da célula D2 é igual ao texto “MANHÔ, retorne “TURMA A”, senão, retorne “TURMA B”

Agora, considere um cadastro de inscritos em um evento para o qual será necessário atribuir automaticamente as situações EM ESPERA ou CONFIRMADO, pelo seguinte critério: se o número da inscrição for menor ou igual a 100, os candidatos ficarão na lista dos participantes confirmados. Os demais ficarão na lista de espera.

Veja como seria a solução para a lista de inscrição que mencionamos no início:

A B C
1 Nº Inscrição Nome do candidato Lista
2 130 ALBERTO PEREIRA =SE(A2<=100;”CONFIRMADO”;”EM ESPERA”)
3 80 ANTONIO FERREIRA =SE(A3<=100;”CONFIRMADO”;”EM ESPERA”)
4 220 ANTONIO SANTOS =SE(A4<=100;”CONFIRMADO”;”EM ESPERA”)
5 5 BRUNO DA SILVA =SE(A5<=100;”CONFIRMADO”;”EM ESPERA”)
6 100 BRUNO FERREIRA =SE(A6<=100;”CONFIRMADO”;”EM ESPERA”)

Como resultado, você encontrará o seguinte:

  A B C
1 Nº Inscrição Nome do candidato Lista
2 130 ALBERTO PEREIRA EM ESPERA
3 80 ANTONIO FERREIRA CONFIRMADO
4 220 ANTONIO SANTOS EM ESPERA
5 5 BRUNO DA SILVA CONFIRMADO
6 100 BRUNO FERREIRA CONFIRMADO

A função SE() está implementada no Microsoft Excel e no Planilhas Google.

Quem gostou, também leu...

Nosso blog necessita utilizar cookies para aprimorar a sua experiência e monetizar nosso conteúdo. Acreditamos que você não veja problemas nisso, mas você pode optar por sair se desejar. Aceitar Saiba mais