Como alternar o valor de uma célula de acordo com mais de um critério?

por Equipe do blog

Você já utiliza a função SE() para avaliar um determinado critério e retornar valores distintos de acordo com o resultado do teste, mas agora deseja tratar mais de um critério simultaneamente, podendo retornar ou não mais resultados predefinidos, o que possivelmente tornará seus testes lógicos mais complexos.

Aprenda a montar essas fórmulas a seguir.

Considere mais de um critério com as funções E() e OU()

Seus testes lógicos podem precisar considerar mais de uma expressão. Em alguns casos, bastará que um critério seja atendido dentre vários outros para que sua fórmula retorne o valor_se_verdadeiro. Em outras situações, você exigirá que todos os critérios sejam atendidos ou, então, seja exibido o valor_se_falso.

Veja exemplos de como utilizar a função E() e a função OU(), conforme necessidade:

Fórmula Descrição do teste lógico
=SE(E(B2>10;C2<=20);5;10) Se o valor da célula B2 é maior que 10 e, necessariamente, o valor da célula C2 é menor ou igual a 20, retorne 5 (VERDADEIRO), senão, retorne 10 (FALSO)
= SE(OU(D2=”MANHÔ;D2=”TARDE”;D2=”NOITE”);”TURNO DEFINIDO”);”PENDENTE”) Se o valor da célula D2 for igual aos textos “MANHÔ ou “TARDE” ou “NOITE”, alternativamente, retorne “TURNO DEFINIDO”, senão, retorne “PENDENTE”

Observe que a quantidade de critérios considerados (testes lógicos) não alterou a quantidade de resultados alternativos (valor_se_verdadeiro e valor_se_falso).

Retorne mais que dois resultados utilizando a função SE() aninhada

O primeiro argumento da função SE() é o teste lógico, a partir do qual você pode definir um valor quando o resultado for VERDADEIRO e outro para quando o resultado for FALSO. A boa notícia é que também podemos aplicar (aninhar) outra função SE() no argumento valor_se_falso, de forma a realizar outro teste lógico, para o qual será possível definir um valor para quando esse segundo teste der VERDADEIRO e outro para quando der FALSO.

Você notou que isso aumentará a quantidade de resultados alternados: de dois (valor_se_verdadeiro, valor_se_falso) para três (valor_se_verdadeiro1, valor_se_verdadeiro2, valor_se_falso). Uma terceira função SE() aninhada poderia lhe dar mais um resultado alternativo (valor_se_verdadeiro1, valor_se_verdadeiro2, valor_se_verdadeiro3, valor_se_falso). E assim por diante.

Veja os exemplos abaixo:

Fórmula Descrição do teste lógico
=SE(B2>10;5;SE(B2=10;10;0)) Se o valor da célula B2 é maior que 10, retorne 5 (VERDADEIRO), senão, se o valor da célula B2 é igual a 10, retorne 10 (VERDADEIRO), senão, retorne 0 (FALSO)
= SE(D2=”MANHÔ;”TURMA A”;SE(D2=”TARDE”;”TURMA B”;SE(D2=”NOITE”;”TURMA C”;”(TURNO DESCONHECIDO)”))) Se o valor da célula D2 é igual ao texto “MANHÔ, retorne “TURMA A”, senão, se o valor da célula D2 é igual ao texto “TARDE”, retorne “TURMA B”, senão se o valor da célula D2 é igual ao texto “NOITE”, retorne “TURMA C”, senão, retorne “(TURNO DESCONHECIDO)”

As funções SE(), E() e OU() estão implementadas no Microsoft Excel e no Planilhas Google.

Quem gostou, também leu...

Nosso blog necessita utilizar cookies para aprimorar a sua experiência e monetizar nosso conteúdo. Acreditamos que você não veja problemas nisso, mas você pode optar por sair se desejar. Aceitar Saiba mais