Como descobrir a quantidade de caracteres (comprimento) de um texto?

por Equipe do blog

Aprenda a contar a quantidade de caracteres de um texto em uma célula ou expressão calculada, utilizando a função NÚM.CARACT().

Conheça outras funções de texto clicando aqui.

Utilizando a função NÚM.CARACT(texto)

A função NÚM.CARACT() permite contar a quantidade de caracteres de um texto em uma célula ou expressão calculada.

Esse comprimento do texto retornado pela função NÚM.CARACT() pode ser utilizado para verificar se existe um mínimo de caracteres preenchidos ou para saber o limite máximo de caracteres a pesquisar em funções de extração de texto ou de localização de partes de um texto em outro.

Se você experimentar a fórmula abaixo em uma célula, observará como resultado o número 17:

=NÚM.CARACT("Rei das Planilhas")

Veja abaixo um exemplo de uso da função NÚM.CARACT() para descobrir se uma célula está vazia:

Copie daqui e substitua a célula C3 pela célula ou pelo texto desejados:

=NÚM.CARACT(C3)

Agora, um exemplo parecido, validando o preenchimento da coluna C com a função lógica SE():

Copie daqui e substitua a célula C13 pela célula ou pelo texto desejados:

=SE(NÚM.CARACT(C13)=0;"Sim";"")

Você também pode deduzir o tipo de documento preenchido pelo comprimento do texto da célula. Para preenchimento de CPF são 11 caracteres, e 14 caracteres para CNPJ:

Copie daqui e substitua a célula C23 pela célula ou pelo texto desejados:

=SE(NÚM.CARACT(C23)=11;"PF";"PJ")

Disponibilidade nos editores de planilha

A função NÚM.CARACT() está implementada no Microsoft Excel e no Planilhas Google.

RETRIBUA COMO PUDER

Você tem Instagram?

Clique aqui para me seguir no @reidasplanilhas! 😀

Compartilhe com seus contatos

Clique em uma das redes sociais abaixo para divulgar esta planilha com amigos e familiares:

Muito obrigado! 😀

Lista de marcadores

Encontre conteúdos semelhantes clicando em um dos marcadores abaixo.

Quem gostou, também leu...

Nosso blog necessita utilizar cookies para aprimorar a sua experiência e monetizar nosso conteúdo. Acreditamos que você não veja problemas nisso, mas você pode optar por sair se desejar. Aceitar Saiba mais