Como localizar determinado padrão dentro de outro texto sem diferenciar maiúsculas?

por Equipe do blog

Aprenda a verificar se um determinado caractere ou texto padrão está contido em um outro texto de uma célula ou expressão calculada, desconsiderando maiúsculas e minúsculas, utilizando a função LOCALIZAR().

Conheça outras funções de texto clicando aqui.

Função LOCALIZAR(texto desejado;texto principal;posição inicial)

A função LOCALIZAR() retorna o valor numérico correspondente à posição do primeiro caractere do texto principal em que há uma ocorrência do texto desejado, a partir de uma posição inicial facultativa.

Diferente da função PROCURAR(), a função LOCALIZAR() desconsidera se o texto desejado está no mesmo padrão de maiúsculas e minúsculas encontrado no texto principal.

No exemplo abaixo, o resultado da função LOCALIZAR() é 3:

=LOCALIZAR("na";"BANANA")

Mudando a posição inicial para desprezar ocorrências anteriores à posição 4, o resultado é 5:

=LOCALIZAR("na";"BANANA";4)

Quando você procura algo que não tem no texto principal, o resultado é o erro #VALOR!:

=LOCALIZAR("na";"BATATA")

Veja um exemplo de pesquisa de uma UF nas células da coluna Cidade/UF da tabela abaixo:

Copie daqui e substitua a célula $B$3 pela célula a pesquisar ou pelo texto fixo desejados e a célula B6 pelas células com o texto principal a ser pesquisado:

=LOCALIZAR($B$3;B6)

Utilizando a função SE() e a função ÉNUM(), você pode testar se o resultado da função LOCALIZAR() é um número mesmo ou se deu aquele erro #VALOR!, evitando que a célula fique preenchida com o valor do erro:

Copie daqui e substitua a célula $B$15 pela célula a pesquisar ou pelo texto fixo desejados e a célula B18 pelas células com o texto principal a ser pesquisado:

=SE(ÉNUM(LOCALIZAR($B$15;B18));"Sim";"")

Utilizando a função LOCALIZAR() com uma posição inicial

Aqui nesse outro exemplo, desejamos pesquisar em uma lista de trechos de viagem quando o código internacional de um aeroporto (nesse caso, o aeroporto de Recife, código REC) apareceu como destino em um dos trechos.

É importante observar que pesquisar apenas pelo código nos trechos da lista não seria suficiente, porque há ocorrências do código REC quando o aeroporto de Recife é uma origem também.

Nesse caso, vamos desprezar as ocorrências do código nas posições anteriores à 4ª posição (que é o hífen, “-“), utilizando o número 4 como posição inicial da pesquisa:

Copie daqui e substitua a célula $B$27 pela célula a pesquisar ou pelo texto fixo desejados, a célula B30 pelas células com o texto principal a ser pesquisado e o número 4 pela posição inicial a pesquisar:

=LOCALIZAR($B$27;B30;4)

Agora, vamos apenas melhorar a fórmula acima, incluindo o tratamento com a função SE() e a função ÉNUM():

Copie daqui e substitua a célula $B$39 pela célula a pesquisar ou pelo texto fixo desejados, a célula B42 pelas células com o texto principal a ser pesquisado e o número 4 pela posição inicial a pesquisar:

=SE(ÉNUM(LOCALIZAR($B$39;B42;4));"Sim";"")

Disponibilidade nos editores de planilha

A função LOCALIZAR() está implementada no Microsoft Excel e no Planilhas Google.

Conheça também a função PROCURAR() no artigo: Como procurar determinado texto dentro de outro texto diferenciando maiúsculas?

RETRIBUA COMO PUDER

Você tem Instagram?

Clique aqui para me seguir no @reidasplanilhas! 😀

Faça uma doação em ambiente seguro

Valorizamos muito pequenas contribuições de até R$ 10,00. Elas são uma ótima maneira de registrar o seu apoio e não comprometem o seu orçamento. Pague-me um cafezinho! 😉

Clique no botão azul, para fazer uma doação:

Compartilhe com seus contatos

Clique em uma das redes sociais abaixo para divulgar esta planilha com amigos e familiares:

Muito obrigado! 😀

Lista de marcadores

Encontre conteúdos semelhantes clicando em um dos marcadores abaixo.

Quem gostou, também leu...

Nosso blog necessita utilizar cookies para aprimorar a sua experiência e monetizar nosso conteúdo. Acreditamos que você não veja problemas nisso, mas você pode optar por sair se desejar. Aceitar Saiba mais