Como avaliar se todas as expressões lógicas em uma fórmula são verdadeiras

por Equipe do blog

=E(teste_lógico 1;[teste_lógico 2];…)

A função E() verifica se todos os testes lógicos (lógico 1, lógico 2 etc.) incluídos são verdadeiros ou não. Se todos forem verdadeiros, a função retornará VERDADEIRO. Se pelo menos um deles for falso, a função retornará FALSO.

Ou seja, E(1<2;4<8;5<=5) retornará VERDADEIRO, pois 1<2, 4<8 e 5<=5 retornam sempre VERDADEIRO. Por outro lado, E(2>0;1=1) retornará FALSO, uma vez que, apesar de 1=1 retornar VERDADEIRO, 2>0 retorna FALSO, ou seja, há pelo menos um critério que retorna FALSO.

Agora, vamos dar uma olhada na planilha representada abaixo, onde os inscritos que atendem ao critério de idade entre 20 e 30 anos serão sinalizados com OK e os demais por “” (caractere vazio):

 ABCD
1Nº InscriçãoNomeIdadeLista
2130ALBERTO PEREIRA23=SE(E(C2>=20;C2<=30);”OK”;””)
380ANTONIO FERREIRA19=SE(E(C3>=20;C3<=30);”OK”;””)
4220ANTONIO SANTOS45=SE(E(C4>=20;C4<=30);”OK”;””)
55BRUNO DA SILVA28=SE(E(C5>=20;C5<=30);”OK”;””)
6100BRUNO FERREIRA27=SE(E(C6>=20;C6<=30);”OK”;””)

Como resultado, você encontrará o seguinte:

 ABCD
1Nº InscriçãoNomeIdadeLista
2130ALBERTO PEREIRA23OK
380ANTONIO FERREIRA19 
4220ANTONIO SANTOS45 
55BRUNO DA SILVA28OK
6100BRUNO FERREIRA27OK

Quem gostou, também leu...

Nosso blog necessita utilizar cookies para aprimorar a sua experiência e monetizar nosso conteúdo. Acreditamos que você não veja problemas nisso, mas você pode optar por sair se desejar. Aceitar Saiba mais

Política de Privacidade e Cookies