Como avaliar se pelo menos uma das expressões lógicas é verdadeira?

por Equipe do blog

Função OU(teste_lógico 1;[teste_lógico 2];…)

A função OU() verifica se pelo menos um dos testes lógicos (lógico 1, lógico 2 etc.) incluídos é verdadeiro ou não. Se ao menos um deles for verdadeiro, a função retornará VERDADEIRO. Apenas quando todos são falsos, a função retornará FALSO.

Ou seja, OU(1>2;4>8;5<=5) retornará VERDADEIRO, pois apesar de 1>2 e 4>8 retornarem FALSO, 5<=5 retorna VERDADEIRO e é suficiente atender a apenas um critério para que a função retorne VERDADEIRO. Como era de se esperar, OU(2<0;1<>1) retornará FALSO, pois tanto 2>0 quanto 1<>1 retornam FALSO.

Bom, vamos acompanhar a planilha representada abaixo, cuja coluna lista será criada segundo os seguintes critérios: o número de inscrição precisa ser menor do que 50 ou pelo menos a idade ser maior que 25 anos. Utilizaremos OK para quem atender a qualquer dos critérios e “” (caractere vazio) para os demais:

 ABCD
1Nº InscriçãoNomeIdadeLista
2130ALBERTO PEREIRA23=SE(OU(A2<50;C2>25);”OK”;””)
380ANTONIO FERREIRA19=SE(OU(A3<50;C3>25);”OK”;””)
4220ANTONIO SANTOS45=SE(OU(A4<50;C4>25);”OK”;””)
55BRUNO DA SILVA28=SE(OU(A5<50;C5>25);”OK”;””)
6100BRUNO FERREIRA27=SE(OU(A6<50;C6>25);”OK”;””)

Como resultado, você encontrará o seguinte:

 ABCD
1Nº InscriçãoNomeIdadeLista
2130ALBERTO PEREIRA23 
380ANTONIO FERREIRA19 
4220ANTONIO SANTOS45OK
55BRUNO DA SILVA28OK
6100BRUNO FERREIRA27OK

Quem gostou, também leu...

Nosso blog necessita utilizar cookies para aprimorar a sua experiência e monetizar nosso conteúdo. Acreditamos que você não veja problemas nisso, mas você pode optar por sair se desejar. Aceitar Saiba mais

Política de Privacidade e Cookies