Como avaliar se pelo menos uma das expressões lógicas é verdadeira?

por Equipe do blog

Função OU(teste_lógico 1;[teste_lógico 2];…)

A função OU() verifica se pelo menos um dos testes lógicos (lógico 1, lógico 2 etc.) incluídos é verdadeiro ou não. Se ao menos um deles for verdadeiro, a função retornará VERDADEIRO. Apenas quando todos são falsos, a função retornará FALSO.

Ou seja, OU(1>2;4>8;5<=5) retornará VERDADEIRO, pois apesar de 1>2 e 4>8 retornarem FALSO, 5<=5 retorna VERDADEIRO e é suficiente atender a apenas um critério para que a função retorne VERDADEIRO. Como era de se esperar, OU(2<0;1<>1) retornará FALSO, pois tanto 2>0 quanto 1<>1 retornam FALSO.

Bom, vamos acompanhar a planilha representada abaixo, cuja coluna lista será criada segundo os seguintes critérios: o número de inscrição precisa ser menor do que 50 ou pelo menos a idade ser maior que 25 anos. Utilizaremos OK para quem atender a qualquer dos critérios e “” (caractere vazio) para os demais:

  A B C D
1 Nº Inscrição Nome Idade Lista
2 130 ALBERTO PEREIRA 23 =SE(OU(A2<50;C2>25);”OK”;””)
3 80 ANTONIO FERREIRA 19 =SE(OU(A3<50;C3>25);”OK”;””)
4 220 ANTONIO SANTOS 45 =SE(OU(A4<50;C4>25);”OK”;””)
5 5 BRUNO DA SILVA 28 =SE(OU(A5<50;C5>25);”OK”;””)
6 100 BRUNO FERREIRA 27 =SE(OU(A6<50;C6>25);”OK”;””)

Como resultado, você encontrará o seguinte:

  A B C D
1 Nº Inscrição Nome Idade Lista
2 130 ALBERTO PEREIRA 23  
3 80 ANTONIO FERREIRA 19  
4 220 ANTONIO SANTOS 45 OK
5 5 BRUNO DA SILVA 28 OK
6 100 BRUNO FERREIRA 27 OK

Quem gostou, também leu...

Nosso blog necessita utilizar cookies para aprimorar a sua experiência e monetizar nosso conteúdo. Acreditamos que você não veja problemas nisso, mas você pode optar por sair se desejar. Aceitar Saiba mais